Blog

My personal blog (old drupal blog: https://www.lordvan.com/drupal/

gentoo, hal + xorg 7.4 (xinput, wacom, synaptics)

Finally figured out what was wrong with my input devices since the upgrade.
It seems that because of the new hal + xinput auto detect stuff things got messed up. I now got working fdi files for both my stylus and my synaptics touchpad :D
After some looking around i had figured out that i need to have my config stuff in .fdi files for hal instead of in my xorg.conf file which was something i should've read in some changelog .. i should really start reading those :D

so I have my wacom fdi file and i extended the default gentoo xinput one. I've attached both.
This does require that the input devices are *not* in /etc/X11/xorg.conf

The problem is that only the stylus works (neither eraser nor touchscreen do) but I mostly use the stylus so i don't really care at the moment. Besides it seems to be a limitation of the auto detection and/or hal which can't configure one device as multiple things or sth like that.
The only way to get that to work again would be to define all input devices manually and set

Section "ServerFlags"
       Option  "AutoAddDevices" "False"
EndSection

Xorg 7.4 and ati-drivers 5.561, touchpad (synaptics)

Upgraded to xorg 7.4 and new ati drivers in hope of them working better as it actually says my model but apparently that only means the desktop model not the laptop one .. still crashes most of the time.
since downgrading was a pita now too i left it and use vesa for now since it's too much of a pain ..

one other thing was that my touchpad stopped workign (and my touchscreen won't really work either - cry) after some google search and dmesg | grep -i touch i found i got asynaptics touchpad and that someone else used that driver for it so i enabled it and put those options.
the scroll area thing doens't work yet but don't really care atm. also need some tweaking in regards to clicking by touching the area. with this just the buttons work .. but better than no mouse ..

Section "InputDevice"
        Identifier  "Touchpad"
        Driver      "synaptics"
        Option      "Device" "/dev/input/event1"
        Option      "Protocol" "event"
        Option      "SpecialScrollAreaRight" "true"
        Option      "Emulate3Buttons"
EndSection

# worked fine in xorg 7.3 but buggered in 7.4 see above
#Section "Inputdevice"
#       Identifier  "Mouse1"
#       Driver      "mouse"
#       Option      "Protocol" "Auto"   # Auto detect
#       Option      "Device" "/dev/input/mouse0" #ice"
#       Option      "Device" "/dev/gpmdata"
# Mouse-speed setting for PS/2 mouse.
###     Option      "ZAxisMapping" "4 5 6 7"
# Emulate3Buttons is an option for 2-button mice
#       Option      "Emulate3Buttons"
#EndSection

Trek Dinner / Meet and Greet Vienna

Going to the Star Trek Meet & Greet today to vienna. It's organized by the Galactic Friendship.
This year's list of (famous) guests is below.
A PDF Flyer(German) can be dowloaded here.

Heute gehen wir zum Star Trek Meet & Greet in Wien. Es wird vom Galactic Friendship organisiert..
Eine diesjährige Gästeliste ist unten.< br />
Ein PDF Flyer kann hier heruntergeladen werden.

Touchscreen and stylus working - yay

Finally got the touchscreen and Stylus to work (duno about eraser part but that's not that important to me ;))
I had to install linux-2.6.27-rc7 for this to work. for some reason this gives me a total of 11 /dev/input/event* devices instead of the total of 5 before but whatever it works.
One other reason why I tried the kernel was cuz I wanted to use both cores of my CPU (2.6.26-gentoo-r7 didn't detect the 2nd core - I checked out the kernel source and it had to do with some bios(?) cpu map ... ) and to have ACPI working as well :)
On a side-note ACPI now works (battery percentage + automatic power off when shutting down)
I had to write patches for the ati-drivers to compile with 2.6.27 (simple ones, which I'll put on gentoo bugzilla and - if i find out where/how - give to ati ... One problem is though that the newest Catalyst 8.9 (8.532) does *not* work on my machine .. it keeps crashing X with some error about atiddxShadow or something .. so I downgraded to 8.8 (8.522) again and modified the patch I wrote to work with that too :) .. Haven't tried any wine games since then but I'm using the same gfx driver ... on the bright side .. Never Winter Nights is cool with a pen :D

Got a HP Pavilion tx2550 toucscreen / tablet laptop ;)

Got a new laptop ;) a HP Pavilion tx2550eg touchscreen laptop / tablet pc.

Progress so far:
ACPI does not work
ati-drivers (closed source) working with xorg-server <=1.5.0 only (1.5.0 is xorg 7.4 which is not supported yet) currently running xorg-server 1.4.2
sound is intel hda which only works so far with model=acer (auto does give mixer, but no sound) unfortunately it does not disable speakers when plugging in a headset (chipset is ALC268)
onboard lan RealTek 8169 (module r8169) working.
WLAN Broadcom 432b chip supposedly detected by broadcom non-OSS driver, but doesn't let me set ESSID and doesn't seem to work ...
touchscreen/pen problems currently prolly cuz wacom driver does not support those devices USB according to page. will investigate.
fingerprint reader *should* work, but didn't try yet
webcam detected and driver loaded .. will test that today.
bluetooth and IRDA still to try
haven't tested the card readers yet but should be able to do that soon too...